Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 23, 2026 - 08:00 UTC
Scheduled
We will be undergoing critical maintenance at this time. Upload and download in the US region will be partially or totally unavailable during the maintenance window.
Posted Sep 23, 2026 - 07:23 UTC
This scheduled maintenance affected: WeTransfer (Downloads, Uploads).