DNS-related issue
Incident Report for WeTransfer
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 20:02 UTC
Monitoring
By 5AM CEST the underlying issue had been resolved by our hosting provider. We continued to monitor and have seen that the fix has not been fully propagated to certain smaller DNS providers yet. We expect this to be fully resolved within the next 12 hours.

If you are still experiencing problems uploading your transfer, please follow the earlier advise of changing your DNS server to Google DNS.
Posted Oct 23, 2019 - 15:53 UTC
Identified
We have identified a DNS-related issue impacting the availability of WeTransfer.com for some of our users, including the uploading of transfers. As the issue originates from our hosting provider, we are currently working with them to get it resolved as soon as possible.

If you’re experiencing DNS resolution errors when using WeTransfer, we suggest you try changing your DNS server to 8.8.8.8 or 8.8.4.4 and try again. You can find more information on how to do this here:

https://wetransfer.zendesk.com/hc/en-us/articles/204436365-Changing-your-DNS-server
Posted Oct 22, 2019 - 21:42 UTC
This incident affected: WeTransfer (Website, Uploads).