Partial outage on the WeTransfer website

Incident Report for WeTransfer

Resolved

The incident has been resolved
Posted Jun 18, 2026 - 14:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2026 - 13:42 UTC

Investigating

The issue has been identified, we are deploying a fix.
Posted Jun 18, 2026 - 13:39 UTC
This incident affected: WeTransfer (Website, Downloads, Uploads, Transfer Mobile, Previews).