Verification is currently underway for the maintenance items.
Posted Mar 17, 2025 - 10:08 UTC
Update
Unfortunately, we experienced major downtime between 09:15 and 09:30 UTC.
We are currently monitoring that services have fully recovered.
Posted Mar 17, 2025 - 10:03 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 17, 2025 - 09:00 UTC
Scheduled
We will be performing planned maintenance to upgrade our infrastructure. This may impact transfers and downloads. If you do experience any issues during this time, please try again after ~10 minutes
Posted Mar 17, 2025 - 08:55 UTC
This scheduled maintenance affected: WeTransfer (Website, Downloads, Uploads, Portals, Transfer Mobile).